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Q.1.

What are the numerous types of impairment that impact computer usage.

Ans. The numerous types of impairment that impact computer usage are :*

Cognitive impairments and learning disabilities, such as dyslexia,
attention deficit-hyperactivity disorder (ADHD) or autism.

*

Visual impairment such as low-vision, complete or partial blindness,
and color blindness.

*

Hearing impairment including deafness.

*

Motor or dexterity impairment such as paralysis, cerebral palsy, or
carpal tunnel syndrome and repetitive strain injury.

Q.2. How to launch the accessibility options.
Ans. To launch accessibility options in Windows XP,
Click Start > Control Panel > Accessibility Options.
Q.3. Define the following :a)

Sticky Keys – Sticky Keys allows the user to press and release a
modifier key, such as Shift, Ctrl, Alt, or the Windows Key, and have it
remain active until any other key is pressed.

b)

Filter Keys – Filter Keys is a feature of Microsoft Windows. It is an
accessibility function that tells the keyboard to ignore brief or
repeated keystrokes, making typing easier for people with hand
tremors.

c)

Toggle Keys – Toggle Keys is a feature of Microsoft Windows. When
Toggle Keys is turned on, computer emits sound cues when the
locking keys (Caps Lock, Num Lock or Scroll Lock) are pressed. A high
sound is emitted when the keys are switched on and a low sound is
emitted when they are switched off.

d)

Serial Keys – Serial Keys is an accessibility feature that assists people
that have difficulty using a keyboard or a mouse (or both). They can
use special devices such as Sip, Puff and Breath Switches to provide
input to the computer through Serial Ports.

Q.4. What is a Computer Network? How Networks are designed.
Ans. A Computer Network is a collection of computers and other hardware
components interconnected by communication channels (cables or
satellites) that allow sharing of resources and information.
Networks are designed using the following architecture :Peer-to-peer Architecture :Networks in which all computers have an equal status are called peer to peer
networks. Generally in such a network each terminal has an equally competent
CPU.
Client Server Architecture :Networks in which certain computers have special dedicated tasks, providing
services to other computers (in the network) are called client server networks.
The computer(s) which provide services are called servers and the ones that use
these services are called clients.
Q.5. What are the advantages associated with networking.
Ans. Some of the advantages associated with networking are :a)

Data Sharing :- Networking allows us to share the data among different
users. We can send text files, spreadsheets, documents etc.

b)

Hardware Sharing :- Hardware components such as Printers, Scanners etc.
can also be shared. Ex. One Printer can be shared among multiple users
with the help of networking.

c)

Internet Access Sharing :- We can purchase a single Internet Connection
and share it with among other computers in a Network instead of
purchasing multiple internet connection for each computer.

d)

Usage of Network based applications :- Such as Web Browsers, Email
clients, chat application, audio & video calling etc. is another advantage.

Q.6. What do you mean by Instant Messaging. What are the key features of
Instant Messaging?
Ans. Instant Messaging is a form of communication over the Internet that offers
an instantaneous transmission of text-based messages from sender to
receiver. It includes the options for performing file transfers, audio chat,
video calling and conferencing etc.
The key features of an Instant Messaging are:a)

Text Messages can be sent to one or more person.
Audio Calling and Conferencing.
Video Calling and Conferencing.

b)

File Transfers (Not limited to documents, spreadsheets, audio files, video
files etc.)

c)

Message History (Save messages for future reference).

Q.7. What are Blogs. List any 5 websites that provide free blog service.
Ans. A Blog is a discussion style site used by non-technical (or technical users)
users for creating personal web pages. We can use a Blog to convey
messages about events, announcements, news, reviews etc.
They are usually managed using a web browser and this requires an active
internet connection.
Some of the popular blogs are :a)

www.WordPress.com

b)

www.blogger.com

c)

www.blog.com

d)

www.weebly.com

e)

www.blogsome.com

Q.8. What are the rules and etiquettes to be followed while chatting on the
internet.
Ans. Rules and etiquettes to be followed while chatting on the internet are :a)

Messages should be short and to the point.

b)

Always introduce yourself by name if your screen name doesnot reflect it.

c)

Typing your messages in uppercase is extremely rude – it’s considered
shouting and very aggressive.

d)

Give time to people to respond it.

e)

Give the person you are communicating with your undivided attention.

Q.9. Briefly explain the types of Internet Connection.
Ans. The Internet connection can be of two types :I)

Wired Connection.

a)

Dial-up connection – To establish a connection to an ISP via telephone line
using a device called Modem. Users dial a particular number provided by
ISP and gain access to the internet. It is usually slow in most cases.

b)

DSL (Digital Subscriber Line) – It provides internet access by transmitting
digital data over wires of a local network. A DSL filter removes the high
frequency interference, enabling simultaneous use of the telephone and
data transmission.

c)

Cale Internet Access – It is a form of broadband internet access that uses
the cable television infrastructure. It is provided through existing cable TV
networks, this is similar to DSL that is provided over existing telephone
lines.

II)

Wireless Connection.

d)

3G : It is a set of standards used for mobile devices and mobile
telecommunication services and networks. We can subscribe to the 3G
connectivity with our ISP in order to get high speed internet connection on
our phone.

e)

WiMAX – It is a wireless communications standard designed to provide
mobile broadband connectivity across cities and countries through a
variety of devices. It is a long range system covering many kilometers and is
typically used where DSL or Cable Internet access cannot be used.

f)

Wi-Fi – Wi-Fi is a popular technology that allows an electronic device such
as computers or mobile phones to exchange data wirelessly over a
network, including high-speed internet connections. Wi-Fi is used where
cables cannot be run (such as old buildings, outdoor areas) to provide
network and internet access. Wi-Fi can also be used where users require
mobile connectivity.

Q.10. Briefly explain types of Instant Messaging Services with example.
Ans. There are two types of instant Messaging Software :a)

Application based instant messaging software is downloaded and installed
on user’s computer. Some of the popular messaging software are :-Google
talk, Yahoo! Messenger, Skype, Windows Live Messenger, Rediff Bol etc.

b)

Web based instant messaging software is accessed using browsers such as
Internet Explorer, Mozilla Firefox, Google Chrome etc. Some of the popular
web based instant messaging servers are : Meebo, Yahoo! Messenger for
the Web, MSN Web Messenger, IMO etc.

Q.11. What is Google Talk?
Ans. Google Talk is an instant messaging services that provides both text and
voice communication developed by Google Inc. It can also be used for
making video calls and to view updates from Gmail mail box. It is a free and
is available as application based (users need to download & install Google
talk application to their desktop, mobiles and laptop) and web based (users
can use Google talk through a browser after signing into their Gmail
account).
Q.12. What are Online Transactions. Explain the purpose of online transactions.
Ans. Online transaction is a form of Electronic commerce where customers can
buy or sell goods over the internet. Customers need to have an active
internet connection for viewing goods or services offered by a seller;
customers can pay online using a credit, debit card or by internet banking.

Online shopping is useful in situations when :*

People do not have sufficient time to visit stores.

*

Visiting a store is more expensive than purchasing a product online.

*

A product or service that is not available in the local market is available
online.

Q.13. Name some popular online transaction websites.
Ans. Few popular online transaction websites are :*

IRCTC, an online portal for booking flight and train tickets.

*

Flipkart, an online shopping portal for buying consumer products.

*

EBay, an online portal for buying and selling goods.

*

Redbus, an online portal for booking bus tickets.

Q.14. List any three payment tools for online transactions.
Ans. Debit card.
Credit card.
Net Banking.
Q.15. Explain the purpose of Internet Security.
Ans. It is a branch of computer security specifically related to the Internet, often
involving browser security but also network security. Its objective is to
establish rules and measures to use against attacks over the internet. The
Internet represents an insecure channel for exchanging information leading
to a high risk of intrusion or fraud, such as phishing, email spoofing.
Q.16. List best practices available for internet security.
Ans. 1.
2.
3.
4.
5.
6.
7.

Use Strong Passwords.
Back-up your data regularly.
Use Encryption software.
Keeping Username and Password private.
Donot share personal information.
Use Antivirus and Anti Spyware software.
Always use Licensed software.
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Q.1.

What are the different types of views available in the spreadsheet.

Ans. The different views available in the spreadsheet are :a)
b)

c)

d)

e)

Normal View – The default view of the spreadsheet application is the
Normal. It’s a collection of cells arranged in the work area.
Page Layout – You can select the Page Layout view in order to quickly fine
tune a worksheet that contains many charts or huge amounts of data
achieve professional looking results.
Page Break Preview – This option is similar to the Page Layout option
except you can set the area that is to be set as a page after inserting page
break.
Custom Views – If you would like to view selected areas of a document,
you can use the custom view option. For example, if you would like to
point out certain row and column, you can add that to the Custom view.
Full Screen – Selecting this option makes the workbook cover the entire
screen. All tabs are hidden from view.

Q.2. How will you open a second instance of a workbook.
Ans. To open a second instance of a workbook in a window :
Click the New Window button on the View tab, in the Window group.
Q.3. Write the steps to arrange Multiple Program Windows.
Ans. To arrange multiple program windows :a)
b)
c)
d)

Click Arrange All button in the Window group. An Arrange Windows dialog
box appears.
Click either Tiled, Horizontal, Vertical or Cascade options.
To include only windows displaying views of the current workbook, select
the Windows of active workbook check box.
Click OK.

Q.4. What is a chart. What are the elements of a chart.
Ans. A chart is a graphical representation of data, in which the data is
represented by symbols, such as bars in a bar chart, lines in a line chart or
slices in a pie chart. A chart can represent tabular numeric data, functions
or some kinds of qualitative structures.
The elements of a chart are :1.
2.
3.
4.
5.
6.
7.

Chart Area of chart.
Plot Area of chart.
Data Points that are plotted in the chart.
Horizontal and Vertical Axis in the chart.
Legend of the chart.
Chart and Axis Title used in the chart.
Data Label for identifying details of data point in the chart.

Q.5. What are the types of chart.
Ans. Types of charts are :a)

Bar charts – A bar chart (horizontal bars) emphasizes the comparison
between items at a fixed period of time. This chart type also includes
cylinder, cone, and pyramid subtypes.

b)

Column charts – A column chart, unlike a bar chart to which it is often
compared, emphasizes variation over a period of time.

c)

Line charts – A line chart shows the relationship of the changes in the data
over a period of time.

d)

Pie charts – Pie charts contain just one chart data series. A pie chart shows
the relationship of the parts of the whole.

e)

Area charts – An area chart shows the relative importance of values over
time.

f)

XY (Scatter) charts – Scatter charts are useful for showing a correlation
among the data points that may not be easy to see from data alone.

Q.6. Explain the difference between a worksheet and a workbook with the help
of an example.
Ans. A worksheet denotes a single spreadsheet page. On the other hand, a
workbook is a collection of all such worksheets in a single file. By default, a
workbook consists of one or more worksheets.
For example, your text book is like a workbook and each page is like an
individual worksheet.
Q.7. Explain the terms ‘Formulas’ in MS Excel.
Ans. Formulas are used to perform calculations involving addition, subtraction,
division and multiplication. A formula establishes a relationship between
two cells.
A formula is an expression that can include cell addresses, numbers,
arithmetic operators and parenthesis. You can perform simple calculations
as well as complex calculations using functions like SUM, IF, MONTH etc.
Formulas must begin with ‘=’ symbol followed by cell references and
operators.
Q.8. What is the difference between Basic Formulas and Compound Formulas.
Ans. Basic Formulas involve only one operator in a formula. For example, if we
want to calculate the sum of a range of cells, we will use only the ‘+’
operator.
Compound Formulas are used when we need more than one operator. For
example, while calculating the Simple Interest, we use the formula,
P*R*T/100. Since more than one operator is involved in the above formula,
it is called a Compound Formula.
Q.9. What could you do to add an absolute reference.

Ans. Add dollar signs around the cell
Q.10. What is the name for the Horizontal Axis of a chart.
Ans. X-Axis.
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Q.1. What is a Database. What are its types.
Q.2. What is RDBMS. How is data organized in a RDBMS.
Q.3. State the relationship & difference between a Primary and Foreign Key.
Q.4. List the data types used in a RDBMS.
Q.5. In a Data base, how can you define the structure of a data and

manipulate the data. Briefly explain.
Q.6. What is the difference between Data Sheet and Design View.
Q.7. What are data types. Explain them.
Q.8. What is the extension of the Database file in MS Office Access.
Q.9. Name the Database Management System from MS Office suite.
Q.10. What do we call the columns in a table.
Q.11. Which key is used to uniquely identify each record in a database table.
Q.12. Name the term which is used to get the synopsis of data on the basis of
some criteria.

Q.13. What do you mean by sorting. How can you sort the data in Access.
Q.14. What is the difference between Data Storing and Data Sorting.
Q.15. Define Tables. List the different elements of a Table.
Q.16. What is the file extension for databases created using OpenOffice.Org
Base.
Q.17. What do you understand by Data Validation. What is the role of Field
Properties in this Process?
Q.18. How can you rename a field.
Q.19. What type of languages we can use to define the structure of data and
manipulate the data in database.
Q.20. What are the two types of DML.
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Q.1. Which feature of word processor helps to improve our vocabulary.
Q.2. List the three different ways of creating a blank document in MS Word.
Q.3. Compare the application of Enter key with the word wrap feature.
Q.4. Explain Application and Document Windows of the MS Word.
Q.5. What do you mean by Formatting. Name the types of Text Formatting
available in MS Word.
Q.6. How will you change the Line spacing of a paragraph.
Q.7. What is a Margin. Explain the different types of Margins.
Q.8. What do you mean by Indent. Explain the types of Indents.
Q.9. What do you understand by Thesaurus. Explain any one method to replace
a word with its synonym.
Q.10. Define the term shapes in MS Word. Explain the steps to insert a shape in a
document.
Q.11. What do you mean by arrangement of graphics in word. Explain the
different arrangements of graphic illustrations.
Q.12. Briefly explain the use of WordArt feature.
Q.13. Explain the process of inserting images from the ClipArt.
Q.14. How can you group several objects into a single object. What are its
advantages.
Q.15. Describe the Office Button in MS Word.
Q.16. How does word help you to keep your document error-free.
Q.17. Define the term “Table”. Explain the utility of a Table in a document.
Q.18. How to insert “Page Number” on every page of a document.
Q.19. How many options are available under Change Case option.
Q.20. Which option in MS word places the selective text below the baseline.
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Q.1. Explain any three basic elements of a slide.
Ans. Title : It is the heading of a slide which is used to guide the audience about
the content of the slide.
Body Text : It contains the main content of the slide, generally formatted as
a bulleted or numbered list.
Background : It is the base of a slide on which various elements like title,
images, charts etc. can be added.
Q.2. Define the term ‘SmartArt’.
Ans. SmartArt is a graphics tool used to create a visual representation of
information, which helps in displaying effective communication of our
ideas. It contains a variety of graphical layouts and diagrams to display data
in a presentation.
Q.3. Explain the three different options of alert message which you receive
while closing a presentation that has not been saved.
Ans. While closing a presentation that has not been saved since the last charge,
you will get the following three options in the message box :Yes : The presentation is saved and then closed.
No : The presentation is closed, and all modifications since the last save are
lost.
Cancel : Nothing happens, and you return to the presentation.
Q.4. What is Slide Show view. How can you access it.
Ans. Slide Show view shows all the slides of your presentation starting either
form the first slide or the current slide one after another. In this view, one
slide occupies the entire screen at a time. In full screen view, you can see
how your graphics, timing, animated elements, movies and transition
effects will look in the actual show.

a)

Click on the Slide Show button present on the Status Bar.

b)

Click on View Tab > Slide Show.

c)

Press F5 to start the Slide Show.

OR

OR

Q.5. What is the function of Slide Sorter view. Explain the steps to delete a
slide in this view.
Ans. The Slide Sorter view contains the thumbnail view of all slides in a
presentation. We use this view to work either with a group of slides or
with a single slide. Click on View tab and select the Slide Sorter button
in the Presentation Views group.
Deleting Slides :*
*

Select the slide/slides, which you want to delete.
To delete a slide, right click on the slide and select the Delete Slide
option from the Shortcut menu or select the Delete button on the
Home tab in the Slides group>or press ctrl+X/Del key.

Q.6. Define the term ‘Slide Master’.
Ans. The Slide Master is an element of the design template that stores
information about the template, placeholder sizes and position of text
or objects, bullet styles, background designs, color schemes and
headers and footers. It basically sets the default layout and formatting
for all other slides. It controls the entire presentation. Any changes
made to the Slide Master page automatically reflect on every page of
the presentation.
Q.7. What are Headers and Footers.
Ans. Headers and Footers are those little identifiers that run across the top
and bottom of the document respectively. Whenever we need to
repeat certain text or graphics on each page, we can use Headers and
Footers. They include information like page numbers, date, book or
chapter titles, author name and Slide Show theme etc. They can also
be modified later.

Q.8. What do you understand by Slide Transitions.
Ans. A slide transition is the visual motion when one slide changes to the
next during a presentation, like Wipe Down, Wipe Left, Wheel
Clockwise etc. These effects make your slide show lively and add
dynamic flair to it.
Q.9. Write the steps to insert your own sound.
Ans. To insert our own sound follow these steps.
a)

Select the slide where you want to insert the recorded sound.

b)

Click on the Sound drop-down arrow in the Media clips group on the
Insert tab.

c)

Choose Record Sound option from the drop-down menu.

d)

A dialog box appear, by default, the sound will be named “Recorded
Sound”.

e)

Press the red button to record, and the square button to stop the
recording.

f)

When you have finished, click on play button.

Q.10. Write the steps to insert from a file.
Ans. To add the sound from a file follow these steps.
a)

Select the slide where you want to add sound.

b)

Select the Insert tab, and click on Sound command in the Media Clips
group.

c)

A dialog box appear, locate the sound file on your computer, and
select the required file. Click on OK.
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Q.1.

How to send an e-mail, write all steps.

Ans. To send an email, follow these steps.
a)
b)

c)
d)
e)
f)
g)
h)

Open any web browser.

Click on Compose button.
Type an email address in “To” box.
To send copy of an email, type the email address in “CC and BCC”.
Write the subject of the email in the subject box.
Type the message in the Message Box.
Click on attachment icon if any attachment is to be sent.
Click on send button.

Q.2. What are the advantages of an email.
Ans. The advantages of an E-mail are :a)
b)
c)
d)
e)
f)

The cost of sending an electronic message is nominal.
the messages are sent and received instantly.
E-mails never get lost and do not reach at the wrong destination.
E-mails allows us to be in touch with the people who are staying far
away.
We can attach pictures, videos, sounds to our emails and send it to
anyone.
We can read, print, forward, reply or delete the received message.

Q.3. What is Outlook calendar. Mention its tasks.
Ans. A calendar software provides an electronic version of a calendar. Mostly
email applications include support for working with calendar through individual
calendar software are also available, for example, Google Calendar. We can
create appointments and events, organize meetings, view group schedules, send
calendars to anyone through email, publish calendars etc.

Q.4. How does Calendar software allows the user to respond to other

user’s meeting requests?
Ans. The steps to create a meeting request are as follows:a)
b)
c)
d)
e)
f)

Click Home tab>New Items command in New Group.
A drop-down menu appears, select Meeting option.
The untitled-Meeting window appear, consist of To, Subject,
Location, Start Time, End Time etc.
Enter the required information in all the fields.
Select the desired option, i.e. Accept, Tentative, Decline or Propose
new time options.
The meeting will be added to your calendar.

Q.5. Write the steps to Print a calendar.
Ans. To Print the calendar, follow these steps.
a)
b)
c)
d)
e)

In the Navigation Pane, select the calendar that you want to print.
Click the File tab > Print option.
Select the required style for the calendar under settings.
To set the other print options, click on Print Option button.
Specify the pages under Printer option and click on Print.

Q.6. Write the steps to scheduling an appointment with the help of calendar.
Ans. To scheduling an appointment, follow these steps.
a)
b)
c)
d)

In Outlook, open a calendar by clicking the Calendar in the
Navigation Pane.
Click the Home tab and then click the New Appointment option in
the New group.
The Untitled Appointment Window appears, enter the details in
Subject box, Location box, Start time and End time boxes.
After entering the information in fields, click the Save & Close option
in the Action group of the Home Tab.

